Eclipse you suck!

I’ve spent several hours trying to get the Android Developer Toolkit version of eclipse to run on Fedora 20. It’s constantly keeps dying with a segfault and libsoup.

[13899.331278] java[15520]: segfault at 0 ip 0000003929c70061 sp 00007fb66bd4df40 error 4 in libsoup-2.4.so.1.7.0[3929c00000+a8000]

I’ve tried all the workarounds on the net which suggest to make it use mozilla, so far no luck.

-Dorg.eclipse.swt.browser.DefaultType=mozilla
-Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib64/xulrunner/

I even deleted my $HOME/.eclipse, that didn’t work. I switched to a new workspace specifically for ADT. Again didn’t help, still constantly dies.

UGH! Piece of Garbage. And to Ajay, no IntelliJ comments :)

About these ads

8 responses to “Eclipse you suck!

  1. I am running ADT on Fedora 20 KDE and there are two bugs that I have encountered.

    One is solved by changing gtk+ theme from oxygen-gtk to any other theme. And second one that you have encountered is solved by using the eclipse.ini command you mentioned in the post.

    “`
    -Dorg.eclipse.swt.browser.DefaultType=mozilla
    “`

    • I tried entering both swt.browser lines in my eclipse.ini. I have ADT installed in /opt/adt-bundle-linux-x86_64-20131030. I added those 2 lines to /opt/adt-bundle-linux-x86_64-20131030/eclipse/eclipse.ini

  2. I’m running eclipse and ADT on FC20 with gnome3 without any problems. It wasn’t a clean install though, The last clean install I did was about FC16.

  3. Hi,

    I’ve a similar segment fault in FC19 with a clear Eclipse 3.7 and 4.2.
    I’ve solved adding this two lines inside eclipse.ini
    -Dorg.eclipse.swt.browser.DefaultType=mozilla
    -Dorg.eclipse.swt.browser.XULRunnerPath=/opt/xulrunner-17.0.1

    As you notice I’ve also downloaded and used xulrunner 17. More recent versions dosn’t solve the fault.

    • I tried entering both swt.browser lines in my eclipse.ini. I have ADT installed in /opt/adt-bundle-linux-x86_64-20131030. I added those 2 lines to /opt/adt-bundle-linux-x86_64-20131030/eclipse/eclipse.ini

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s